Скачать Counter-Strike 1.6 для Linux - Soft-Game.Net
Добро пожаловать на игровой портал Регистрация Вход

Counter Strike 1.6

Counter Strike: Source

Counter-Strike 1.6 для Linux

Загрузок: 969

Описание:
Обновленная версия популярнейшей игры Counter-Strike 1.6.
Это оригинальная версия игры, поэтому в ней присутствуют только стандартные модели игроков и оружия, отсутствуют лишние спрайты и модели – очень легкая сборка для вашей Linux.


Порядок установки
Разархивируйте Counter-Strike.tar.gz.
Выставите файлу Install.sh права на выполнение и запустите в терминале.
Если возникают ошибки, читайте "Часто задаваемые вопросы"

Часто задаваемые вопросы (FAQ)

Как запустить игру:
С ярлыка на рабочем столе, если ярлык потерялся, установите игру повторно.
Для повторной установки, скопируйте содержимое папки install в корневую папку игры и запустите Install.sh в терминале.
Или можно выставить файлу cstrike.sh права для выполнения и открывать игру в терминале


Как сменить язык
Для выбора языка запустите скрипт langchanger.sh (через Терминал, Zenity или KDialog) и выберите нужный язык.
Если в меню нету русского языка, значит он уже выставлен.


Не ставиться .sh файл на выполнение
Установите ntfs-config и поставьте галочки:
Включить поддержку записи для внешнего устройства
Включить поддержку записи для внутреннего устройства

Для 64-битных систем
32-битной игре на 64-битной системе требуются 32-битные библиотеки (ia32-libs). Для их установки:
sudo -i
cd /etc/apt/sources.list.d

echo "deb http://old-releases.ubuntu.com/ubuntu/ raring main restricted universe multiverse" >ia32-libs-raring.list
apt-get update
apt-get install ia32-libs
rm /etc/apt/sources.list.d/ia32-libs-raring.list
Альтернатива (если не помогли основные):
apt-get update
sudo apt-get install gcc-multilib


Нет такого файла или каталога (No such file or directory)
См. вопрос "Для 64-битных систем"

Failed to load the launcher
См. вопрос "Для 64-битных систем"
Если ошибка все равно возникает, это вызвано из-за старой версии
libc6, требуется >= 2.15.
sudo apt-get update
sudo apt-get install --only-upgrade libc6:i386
или
sudo apt-get install --only-upgrade '^libc6.*'
Если нет возможности обновить системный libc6, то скачайте пакет и распакуйте все библиотеки из lib/i386-linux-gnu в <каталог_с_игрой>/bin


Ошибка OpenGL extensions S3TC texture support
В: Ошибка:
This application requires either the GL_EXT_texture_compression_s3tc, or the GL_EXT_texture_compression_dxt1 + GL_ANGLE_texture_compression_dxt3 + GL_ANGLE_texture_compression_dxt5 OpenGL extensions. Please install S3TC texture support.
или
Required OpenGL extension "GL_EXT_texture_compression_s3tc" is not supported. Please install S3TC texture support.
О: См. вопрос "Для 64-битных систем"Если ошибка все равно возникает, в терминале
sudo apt-get update
sudo apt-get install libtxc-dxtn-s2tc0:i386


Ошибка: Unable to load module vguimatsurface.so!
В: Ошибка:
AppFramework : Unable to load module vguimatsurface.so!
Unable to load interface VGUI_Surface030 from vguimatsurface.so
О: См. вопрос "Для 64-битных систем" (вопрос выше). Если ошибка все равно возникает, каталоге с игрой выполните:
$ LD_LIBRARY_PATH=bin ldd bin/vguimatsurface.so
и установите недостающие зависимости.


Ошибка: SDL_GL_LoadLibrary(NULL) failed: Failed loading libGL.so.1: libGL.so.1
См. вопрос "Для 64-битных систем" (вопрос выше). Или
sudo apt-get update
sudo apt-get install libnss3:i386

Предупреждение: WARNING: setlocale('en_US.UTF-8') failed, using locale:'C'. International characters may not work.
Сгенерируйте en_US.UTF-8 локаль, иначе при каждом запуске будет выскакивать предупреждении.

Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]

Вход на сайт


Оформи подписку

Статистика


Онлайн всего: 2
Гостей: 2
Пользователей: 0